PCEFTPOS Agent is not working

PCEFTPOS Agent is not working

Solution: PCEFTPOS 

 

Business System: Infrasys

 

Symptom

Sometimes the PCEFTPOS Agent is not functional even the Agent icon is displayed in the task bar. This will result in ‘Fail to sale’ error message while processing credit card payment.

 

Cause

The PCEFTPOS Agent task was killed abnormal therefore the POS workstation can’t communicate with the SPA Server for the payment request.

 

Identifying the issue

If ‘Fail to sale’ pops up in Infrasys, check the following information: 

  1. Check PEPAgent.log of PCEFTPOS Agent, no update information was added to the log file.
  2. Check the SPA spa-debug log, ‘SPA Error:Sale, Pinpad Read timed out’ can be found for the relative terminal.
  3. Check the POS workstation, the PCEFTPOS Agent icoin is in the task bar.

Grab the PEPAgent.log from POS workstation, if no updated information can be found to the log file then the Agent task was killed.

 

Resolution

Restart the PCEFTPOS Agent by below processes can resolve this issue.

  1. Press the 'Show hidden icons' button on the bottom right corner of Windows Desktop.
  2. Find the PCEFTPOS Agent icon then press and hold on it to popup the Exit window.
  3. Press the Exit button.
  4. Press Yes to exit the PCEFTPOS Agent.
  5. Find the 'StartAgent' icon on Windows Desktop then double tap on it to start the Agent.
  6. Once the Agent is started, the Agent icon can be found around the 'Show hidden icons'.

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